As a provider of an essential service, we are working to ensure we are here for our customers, our community and our employees as coronavirus impacts the region.

With Governor Inslee’s Safe Start Washington county-by-county phased re-opening approach, PSE is gradually returning maintenance and construction crews back into the field and offices. PSE’s highest priority is the health and safety of our employees and communities. As such, we continue to adhere to current CDC guidance regarding COVID-19 while working in our community.

We are requiring our employees to maintain physical distancing while working in the field and offices. We encourage our customers to do the same when engaging with our employees.

Residential Customers
Small Business Customers

Browser Support

For the best user experience

The following browsers are recommended by SAP for use with the SAP e-Recruiting system:

  • Apple Safari version 5.1, 6 or 7
  • Firefox (latest release)
  • Microsoft Internet Explorer version 8 - 11
  • Chrome (latest release)
  • Adobe Reader 10.1.3 or higher (plugin for your browser)

Browser settings

Most screens will open and display in a new window. Be sure to turn off any pop-up blockers in your browser settings.

If you encounter issues, make sure your browser is set to accept cookies. This will enable you to stay signed in to your profile.

For personal security and to prevent illegal access to your profile, please always remember to click the “Sign Out” link and close your browser when finished, especially if you are using a public computer.

Current support

This table describes the compatibility of some popular browsers with the eRecruiting application.

Browser Type and Version OS Status
IE 8, 9 Vista, Windows7 Partial support
IE 10, 11 Windows7 Full support
IE 10, 11 Windows8 desktop Partial support
Google Chrome (latest release) Windows7, Windows8 desktop Partial support
Firefox (latest release) Vista, Windows7, Windows8 desktop Full support
Safari 5.1 Mac OS 10.6, 10.7 Full support
Safari 6.0 Mac OS 10.7, 10.8 Full support
Safari 7.0 Mac OS 10.9 Full support